ZenCart 137 fresh install: Errore ezpages

Segnalazione Bug della distribuzione in relazione alle versioni fino alla 1.5.3

Moderatori: Sandro Carniel aka webmaster, Paolo De Dionigi aka Spike00

romaninz
Messaggi: 7
Iscritto il: gio giu 01, 2006 2:32 pm

ZenCart 137 fresh install: Errore ezpages

Messaggioda romaninz » ven gen 19, 2007 12:04 pm

Dopo aver installato e cambiato al mio solito tema utilizzato con la 1.3.6 ho il seguente errore:

1054 Unknown column 'pages_title' in 'order clause'
in:
[select * from ezpages where status_header = 1 and header_sort_order > 0 order by header_sort_order, pages_title]

Ho letto da qualche parte che è un problema delle ezpages multilingua. Come faccio a bypassarlo?

Avatar utente
Paolo De Dionigi aka Spike00
Site Admin
Messaggi: 1691
Iscritto il: mar feb 08, 2005 10:41 am
Località: Busto Arsizio (VA)
Contatta:

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda Paolo De Dionigi aka Spike00 » ven gen 19, 2007 12:18 pm

prendi questi files:

includes/modules/classic/ezpages_bar_footer.php
includes/modules/classic/ezpages_bar_header.php
includes/modules/sideboxes/classic/ezpages.php

e li copi nelle corrispondenti cartelle con il nome del tuo template

devi verificare anche la presenza dei pulsanti nuovi che sono stati aggiunti e le modifiche al css.
1)Studiare questo documento prima di fare una domanda: http://url.zen-cart.it/faq
2)CERCA CERCA CERCA CERCA CERCA!

wanlorn
Messaggi: 64
Iscritto il: dom gen 14, 2007 11:49 am

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda wanlorn » ven gen 19, 2007 12:47 pm

Ciao io ho lo stesso problema, ho installato la 1.37 da zero, cancellando la 1.36, tanto sto facendo esperimenti e non ho perso molto :P
Ho installata anche il template mostlygrey
Ho riscontrato il suo stesso problema, ho seguito i tuoi suggerimenti Spike e la parte centrale della pagina appare, senza più quell errore.
Non cui sono però le barre laterali, sono andato allora nell'opzione side box e ho riscontrato che questa riga
sideboxes/mostlygrey/ezpages.php mi risulta rossa
cosa devo fare?
se provo a caricare la pagina mi esce quest errore nella zona laterale del template e sparisce anche la parte centrale

54 Unknown column 'pages_title' in 'order clause'
in:
[select * from ezpages where status_sidebox = 1 and sidebox_sort_order > 0 order by sidebox_sort_order, pages_title]

Avatar utente
Paolo De Dionigi aka Spike00
Site Admin
Messaggi: 1691
Iscritto il: mar feb 08, 2005 10:41 am
Località: Busto Arsizio (VA)
Contatta:

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda Paolo De Dionigi aka Spike00 » ven gen 19, 2007 1:14 pm

Strano.

Il fatto che in admin -> side boxes quel box sia in rosso è normale, perchè serve per identificare i box 'overridati'.

L'errore che ti da è proprio l'errore che ti darebbe se non avessi il file ezpages.php nella cartella col nome del template in sideboxes.

Controlla che non ci siano problemi con il file (che sia integro) (banalmente copialo in classic e switcha sul template classic e vedi se funziona), controlla anche che non ci siano errori di scrittura nel nome della cartella e del file:

sideboxes/mostlygrey/ezpages.php

Sembra proprio che non riesca a leggerlo
1)Studiare questo documento prima di fare una domanda: http://url.zen-cart.it/faq
2)CERCA CERCA CERCA CERCA CERCA!

romaninz
Messaggi: 7
Iscritto il: gio giu 01, 2006 2:32 pm

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda romaninz » lun gen 22, 2007 9:23 am

Grazie mille per l'aiuto!!!

Solo una piccolissima critica costruttiva: probabilmente la cosa dovrebbe essere segnalata nel file README.

Grazie ancora!

Avatar utente
Paolo De Dionigi aka Spike00
Site Admin
Messaggi: 1691
Iscritto il: mar feb 08, 2005 10:41 am
Località: Busto Arsizio (VA)
Contatta:

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda Paolo De Dionigi aka Spike00 » lun gen 22, 2007 9:37 am

Hai perfettamente ragione. L'avevamo già pensato, ma non ancora messo in pratica.
1)Studiare questo documento prima di fare una domanda: http://url.zen-cart.it/faq
2)CERCA CERCA CERCA CERCA CERCA!

wanlorn
Messaggi: 64
Iscritto il: dom gen 14, 2007 11:49 am

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda wanlorn » lun gen 22, 2007 11:53 am

allora ho provato a fare come dici tu, e anche se il file ezpages.php lo sposto in classic la scritta sideboxes/classic diventa rossa,
ho provato allora a inserire di nuovo nella classic quella originale dall'installazione della 1.37 e anche così mi resta rossa...
che sto combinando di sbagliato?
non ho idea sinceramente di dove possa essere l'errore

Avatar utente
Paolo De Dionigi aka Spike00
Site Admin
Messaggi: 1691
Iscritto il: mar feb 08, 2005 10:41 am
Località: Busto Arsizio (VA)
Contatta:

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda Paolo De Dionigi aka Spike00 » lun gen 22, 2007 12:19 pm

Il rosso sta ad indicare che quel box non è quello di default. E' giusto che compaia in rosso anche se usi il template 'classic', perchè non è il template di default. (Qui si genera confusione: nell'accezione normale del termine, è vero che classic è il template di default perchè quello incluso nella distribuzione, ma in questo caso, con il termine default intendo proprio ciò che Zen Cart utilizza come terminologia nel codice: ovvero template_default.
I box che non si trovano [b]solo[/b] nella cartella template_default/sideboxes, ma hanno un corrispondente in classic/sideboxes o tuo_template/sideboxes, compariranno in rosso.
Ma questo non significa che ci sia un errore).

A parte il rosso, l'errore c'è sempre? anche se usi il template classic (con contenuto originale, non modificato)?
1)Studiare questo documento prima di fare una domanda: http://url.zen-cart.it/faq
2)CERCA CERCA CERCA CERCA CERCA!

0TheX0
Messaggi: 26
Iscritto il: mar gen 23, 2007 3:30 pm

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda 0TheX0 » mar gen 23, 2007 6:34 pm

Grazie a queste modifiche sono riuscito a crearmi un nuovo template anche con la 1.3.7 :D
La mente � una cosa meravigliosa....tutti dovrebbero avercene una!

Luca79
Messaggi: 4
Iscritto il: ven feb 02, 2007 3:17 pm

Re: ZenCart 137 fresh install: Errore ezpages

Messaggioda Luca79 » ven feb 02, 2007 3:25 pm

ciao ragazzi. Ho lo stesso problema. Installo da 0 la 1.3.7 e quando vado a crearmi un template personale anche dopo il reset dei box laterali mi da quell'errore.

Non ho capito però quali files devo spostare e dove soprattutto.

Grazie!


Torna a “Bug versioni fino alla 1.5.3”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite